• fzzzy
    haha, i just saw a deprecation warning in a console screenshot that says "frame-src is deprecated, please use child-src", but when I was writing the branch I switched to frame-src because child-src was deprecated
  • fzzzy
    wat
  • CosminMCG
    Hi guys, as we mentioned yesterday, we run the Test Pilot deployment verification on production today and we haven't found any new issues
  • CosminMCG
    so, production looks good
  • CosminMCG
    we also looked over the mozilla/testpilot #2746, but we haven't managed to reproduce it
  • fzzzy
    thanks CosminMCG! huge release!
  • fzzzy
    eeems said that #2746 went away if they used a fresh profile so that is good. wonder what the issue was though. maybe they can provide the broken profile
  • JSON_voorhees
    Updated the description to the latest min vid pr to explain what _actually_ needs to be reviewed in it last night meandavejustice/min-vid #957
  • JSON_voorhees
    If anyone can take a look today I would really appreciate it
  • jgruen
  • jgruen
    hot off twitter
  • fzzzy
    jgruen: we had a discussion about this yesterday, but couldn't decide what the right thing to do was
  • jgruen
    on irc?
  • fzzzy
    jgruen: we add languages to the languages meta tag when they reach 100%, but don't remove them when they fall below 100%
  • fzzzy
    yeah
  • jgruen
    ah, well seems like 1 language would be good
  • jgruen
    and en should be 100%
  • lorchard
    That's actually accept-languages working as intended :/
  • jgruen
    yeah i know
  • jgruen
    there used to be a process that cloned en-US to en
  • lorchard
    But what we need to do is get the l10n branch working and hold back features until there's enough languages at 100%
  • lorchard
    removing a language from the list means suddenly the *whole site* is no longer in that language
  • lorchard
    cloning en-US to en wouldn't help
  • lorchard
    at least, I don't think
  • lorchard
    Problem is that not all locales are at 100% on new content
  • fzzzy
    russian has some of the new content translated, but not all of it. so whatever is translated shows up in russian, but whatever isn't falls back to english
  • jgruen
    user says the site used to be 100% english in the case in the bug
  • lorchard
    That's weird
  • lorchard
    Because the old l20n system would not show anything but l10n IDs before now, no fallback strings
  • lorchard
    This new fluent system at least does fallbacks at all
  • fzzzy
    jgruen: we manually manage the language list, russian only would have been added to it at a point when translation coverage reached 100
  • lorchard
    It was 100% at one point
  • lorchard
    Beyond there, we don't remove the language from the list, we should hold back content until it's back to 100%
  • lorchard
    Or decide we're okay with fallbacks in some languages because it's more important to lauinch
  • lorchard
    removing a language from the list is way too drastic IMO
  • fzzzy
    it was added jan 3
  • fzzzy
    I tested that both en and en-US are working properly
  • jgruen
    so with content negotiation, assuming en would be 100% too, why is that not showing up?
  • jgruen
    is it a coin flip when they're at the same q value
  • fzzzy
    if en is at the top it should grab en first
  • jgruen
    and if so it seems like the complete locale would win?
  • jgruen
    user's accept header looks like this: en,ru;q=0.7,ja;q=0.3
  • jgruen
    i am not actually sure how to read that precisely
  • lorchard
    Hmm, yeah, maybe it is the lack of an en locale, since q=1.0 by default
  • jgruen
    that's what i thought
  • jgruen
    i think this is that, rather than a negotiation issue...
  • lorchard
    Does fluent have a way to alias a language to a locale? Seems like there should be a cleaner way to do it than just copying certain locales to respective languages
  • lorchard
    I think we did that for legal page URLs or something, but not for the site in general
  • fzzzy
  • fzzzy
    en is there
  • fzzzy
    lorchard: that was on my list to ask s t a s about soon
  • lorchard
    It's not in the production locales list though
  • fzzzy
    oh, whoops
  • fzzzy
    I guess that's the bug then
  • lorchard
    or wait, I'm looking at snooze tabs
  • lorchard
    Ah yeah, nope, not on test pilot either
  • fzzzy
  • fzzzy
    i think we also want to add de-de
  • jgruen
    fzzzy lorchard the user from twitter posted a further screenshot. could we track the issue for that bug
  • jgruen
    seems like good karma
  • lorchard
    Not sure what that means... are you posting the screenshot in that issue?
  • fzzzy
    it's there
  • jgruen
  • fzzzy
    yeah i can't understand that sentence either. you mean use the bug to discuss the issue?
  • lorchard
    Yeah, I didn't understand the sentence
  • fzzzy
    the fix is adding en and de-de to this line github.com/mozilla/testpilot/blob/master/frontend/config.js#L13
  • jgruen
    oh, i was saying it would be good karma for us to provide an update un that bug
  • jgruen
    *in that bug
  • fzzzy
    i'm on a branch right now but i can do it in like 20 minutes if nobody else does
  • lorchard
    Well, the update is probably going to be the fix that fzzzy is working on right now
  • lorchard
    Oh, thought you were actually on it
  • lorchard
    I can do it real quick, so either way the update is - here's a fix for next push
  • lorchard
    (assuming adding it to the production locale list fixes it)
  • jgruen
    yeah commented on the bug
  • jgruen
    thanks!
  • lorchard
    hmm, I don't see en or de-de locales on a local build... do we only copy those on deploy?
  • fzzzy
    i think so. i would like it if they worked for local too
  • lorchard
    not seeing it in deploy.sh :/
  • fzzzy
    clouserw: do you remember where en-US gets copied to en?
  • clouserw
    fzzzy: sorry, no
  • fzzzy
    nobody knows then! haha
  • fzzzy
    is it in an ops script?
  • lorchard
  • fzzzy
    must be then
  • lorchard
    Unless the en locale on prod is super stale and we don't actually generate it anymore
  • fzzzy
    hmm
  • lorchard
    Yeah, I think it's stale. No mention of new content
  • lorchard
    Last-Modified: Mon, 17 Apr 2017 18:00:36 GMT in the headers
  • fzzzy
    i don't see send or notes in there
  • lorchard
    So, probably a little more to be done than just adding it to the locales list
  • fzzzy
    having fluent-langneg support locale aliases would be nice
  • lorchard
    So yeah, I don't think I'm fixing this real quick
  • » fzzzy nods
  • fzzzy
    at least there is a bug open for it now. thanks jgruen
  • fzzzy
    I was writing the exact same comment lorchard wrote but he beat me hehe
  • fzzzy
    ok back to removing the user counts ;)
  • lorchard
    Hmm, yeah, I wonder if we can just stick a conditional in the bit that loads the languages
  • lorchard
    rather than copy files around
  • fzzzy
  • fzzzy
    it looks like it has multiple algos for matching
  • fzzzy
    hmm likelySubtags looks like what we want
  • lorchard
    Ah okay, yeah better using that than trying to reinvent that wheel
  • fzzzy
    is there a tool to simulate a slow connection over localhost?
  • fzzzy
    apple devtools have the "network link conditioner"
  • fzzzy
    more people are reporting this "e is null" error, but why can none of us repro it :(
  • lorchard
    I see the error in Sentry, too, but it seems to be coming from a stack of React calls that don't make a lot of sense to me
  • Caspy7
    In his "Security Now" video podcast Steve Gibson gives Firefox Send his full endorsement with a nice description and breakdown of how it works youtu.be/cWZqpCe-cvA?t=4706
  • chuck
    And the SDK is out!
  • chuck